Oracle dataguard (RFS process doesnot start)

All posts relating to Oracle database administration.

Moderator: Tim...

Oracle dataguard (RFS process doesnot start)

Postby manishkumar08 » Tue Oct 09, 2012 7:42 am

Hi Tim,

I have been facing one issue regarding DataGuard 10g(10.2.0.4), the RFS processes is not starting at DR end.
There was a n/w issue at my site on 3rd Oct and later it got resolved by 6th Oct. Later we had transferred all pending archives to DR server.
Then brought Dr in sync with prod by manual recovery
Code: Select all
RECOVER STANDBY DATABASE;


Then started managed recovery process and confirmed prod and DR in sync.
Code: Select all
 ALTER DATABASE RECOVER MANAGED STANDBY DATABASE DISCONNECT FROM SESSION;


later applied few log switches at prod.
i have checked with v$managed_standby view at Dr but there is no entry of RFS processes, even after 2 days it doesnt start.
Code: Select all
SQL> select process,status from v$managed_standby;

PROCESS   STATUS                                                                                                                                                                                       
--------- ------------                                                                                                                                                                                 
ARCH      CONNECTED                                                                                                                                                                                     
ARCH      CONNECTED                                                                                                                                                                                     
MRP0      WAIT_FOR_LOG                                                                                                                                                                                 



At production there is no error showing in v$archive_dest view.
Code: Select all
SQL> select error from v$archive_dest;

ERROR                                                                                                                                                                                                   
-----------------------------------------------------------------                                                                                                                                       
 


Nor any messages at v$dataguard_status view at production.

Code: Select all
SQL> select message,timestamp from v$dataguard_status;

MESSAGE                                                                                                                                                                                                 
-------------------------------------------------------------
TIMESTAMP                                                                                                                                                                                               
---------

ARC2: Destination LOG_ARCHIVE_DEST_2 network reconnect abandoned                                                                                                                                       
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
ARC1: Attempting destination LOG_ARCHIVE_DEST_2 network reconnect (3135)                                                                                                                               
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
ARC1: Destination LOG_ARCHIVE_DEST_2 network reconnect abandoned                                                                                                                                       
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
FAL[server, ARC3]: FAL archival, error 16041 closing archivelog file 'standby'                                                                                                                         
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
ARC5: Attempting destination LOG_ARCHIVE_DEST_2 network reconnect (3135)                                                                                                                               
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
ARC5: Destination LOG_ARCHIVE_DEST_2 network reconnect abandoned                                                                                                                                       
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                     
FAL[server, ARC2]: FAL archival, error 16041 closing archivelog file 'standby'                                                                                                                         
03-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                           
-- Connected User is Valid                                                                                                                                                                             
05-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
Redo Shipping Client Connected as PUBLIC                                                                                                                                                               
05-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
-- Connected User is Valid                                                                                                                                                                           
05-OCT-12
                                                                                                                                                                                                   
Redo Shipping Client Connected as PUBLIC                                                                                                                                                               
05-OCT-12                                                                                                                                                                                               
                                                                                                                                                                                                       
-- Connected User is Valid                                                                                                                                                                             
05-OCT-12                                                                                                                                                                                                                                         



I have tried recreating new Standby controlfile also.

Please suggest how to resolve this issue.

Regards,
Manish
manishkumar08
Member
 
Posts: 32
Joined: Wed Feb 24, 2010 7:40 am

Re: Oracle dataguard (RFS process doesnot start)

Postby Tim... » Tue Oct 09, 2012 5:13 pm

Hi.

Try:

- Shut down the standby.
- Start it in managed recovery mode.
- If it doens't work as expected, raise an SR with Oracle support.

Cheers

Tim...
Tim...
Oracle ACE Director
Oracle ACE of the Year 2006 - Oracle Magazine Editors Choice Awards
OakTable Member
OCP DBA 7.3, 8, 8i, 9i, 10g, 11g
OCP Advanced PL/SQL Developer
Oracle Database: SQL Certified Expert
My website: http://www.oracle-base.com
My blog: http://www.oracle-base.com/blog
Tim...
Site Admin
 
Posts: 17937
Joined: Mon Nov 01, 2004 5:56 pm
Location: England, UK


Return to Oracle Database Administration

Who is online

Users browsing this forum: No registered users and 6 guests

cron